re = /^(?P<repository>[\w.\-_]+((?::\d+|)(?=\/[a-z0-9._-]+\/[a-z0-9._-]+))|)(?:\/|)(?P<image>[a-z0-9.\-_]+(?:\/[a-z0-9.\-_]+|))(:(?P<tag>[\w.\-_]{1,127})|)$/mi
str = 'alpine
alpine:latest
_/alpine
_/alpine:latest
alpine:3.7
docker.example.com/gmr/alpine:3.7
docker.example.com:5000/gmr/alpine:latest
pse/anabroker:latest'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end