#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?P<repository>[\w.\-_]+((?::\d+|)(?=/[a-z0-9._-]+/[a-z0-9._-]+))|)(?:/|)(?P<image>[a-z0-9.\-_]+(?:/[a-z0-9.\-_]+|))(:(?P<tag>[\w.\-_]{1,127})|)$"
Local $sString = "alpine" & @CRLF & _
"alpine:latest" & @CRLF & _
"_/alpine" & @CRLF & _
"_/alpine:latest" & @CRLF & _
"alpine:3.7" & @CRLF & _
"docker.example.com/gmr/alpine:3.7" & @CRLF & _
"docker.example.com:5000/gmr/alpine:latest" & @CRLF & _
"pse/anabroker:latest"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")