import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<repository>[\\w.\\-_]+((?::\\d+|)(?=/[a-z0-9._-]+/[a-z0-9._-]+))|)(?:/|)(?P<image>[a-z0-9.\\-_]+(?:/[a-z0-9.\\-_]+|))(:(?P<tag>[\\w.\\-_]{1,127})|)$";
final String string = "alpine\n"
+ "alpine:latest\n"
+ "_/alpine\n"
+ "_/alpine:latest\n"
+ "alpine:3.7\n"
+ "docker.example.com/gmr/alpine:3.7\n"
+ "docker.example.com:5000/gmr/alpine:latest\n"
+ "pse/anabroker:latest";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}