re = /(?<=SMS: )\+?\d*/m
str = 'Contact me
Please mention you found my ad on sex-tjejer.com! Thank you!
Call: 0764245243
or
SMS: 0764245243
WhatsApp: +46764245243
Close'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end