#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=SMS: )\+?\d*"
Local $sString = "Contact me" & @CRLF & _
"Please mention you found my ad on sex-tjejer.com! Thank you!" & @CRLF & _
"Call: 0764245243" & @CRLF & _
"or" & @CRLF & _
"SMS: 0764245243" & @CRLF & _
"WhatsApp: +46764245243" & @CRLF & _
"Close"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")