const regex = /(?<=SMS: )\+?\d*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=SMS: )\\+?\\d*', 'gm')
const str = `Contact me
Please mention you found my ad on sex-tjejer.com! Thank you!
Call: 0764245243
or
SMS: 0764245243
WhatsApp: +46764245243
Close`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}