use strict;
my $str = 'Contact me
Please mention you found my ad on sex-tjejer.com! Thank you!
Call: 0764245243
or
SMS: 0764245243
WhatsApp: +46764245243
Close';
my $regex = qr/(?<=SMS: )\+?\d*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}