re = /^(\+7|8)(\s|-)?(\()?[0-9]{3}(\))?(\s|-)?([0-9]{3})(\s|-)?([0-9]{2})(\s|-)?([0-9]{2})$/m
str = '+79295002639
8 929 500 2639
+7 (929) 500 26-39
8 (929) 500 2639
8-9295002639
8478393
65748499
fkjhkhfs75768
+75836fjhgdlhg
[?:+7|8][?:\\s|\\-]\\(?[0-9]{3}\\)?[?:\\s|\\-][0-9]{3}[?:\\s|\\-][0-9]{2}[?:\\s?|\\-][0-9]{2}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end