# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\+7|8)(\s|-)?(\()?[0-9]{3}(\))?(\s|-)?([0-9]{3})(\s|-)?([0-9]{2})(\s|-)?([0-9]{2})$"
test_str = ("+79295002639\n"
"8 929 500 2639\n"
"+7 (929) 500 26-39\n"
"8 (929) 500 2639\n"
"8-9295002639\n"
"8478393\n"
"65748499\n"
"fkjhkhfs75768\n"
"+75836fjhgdlhg\n"
"[?:+7|8][?:\\s|\\-]\\(?[0-9]{3}\\)?[?:\\s|\\-][0-9]{3}[?:\\s|\\-][0-9]{2}[?:\\s?|\\-][0-9]{2}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.