using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+7|8)(\s|-)?(\()?[0-9]{3}(\))?(\s|-)?([0-9]{3})(\s|-)?([0-9]{2})(\s|-)?([0-9]{2})$";
string input = @"+79295002639
8 929 500 2639
+7 (929) 500 26-39
8 (929) 500 2639
8-9295002639
8478393
65748499
fkjhkhfs75768
+75836fjhgdlhg
[?:+7|8][?:\s|\-]\(?[0-9]{3}\)?[?:\s|\-][0-9]{3}[?:\s|\-][0-9]{2}[?:\s?|\-][0-9]{2}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}