import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+7|8)(\\s|-)?(\\()?[0-9]{3}(\\))?(\\s|-)?([0-9]{3})(\\s|-)?([0-9]{2})(\\s|-)?([0-9]{2})$";
final String string = "+79295002639\n"
+ "8 929 500 2639\n"
+ "+7 (929) 500 26-39\n"
+ "8 (929) 500 2639\n"
+ "8-9295002639\n"
+ "8478393\n"
+ "65748499\n"
+ "fkjhkhfs75768\n"
+ "+75836fjhgdlhg\n"
+ "[?:+7|8][?:\\s|\\-]\\(?[0-9]{3}\\)?[?:\\s|\\-][0-9]{3}[?:\\s|\\-][0-9]{2}[?:\\s?|\\-][0-9]{2}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}