$re = '/\A\w+_BM__[0-9]{1,6}_[0-9]{1,6}\z/m';
$str = 'RP_BM_IM_17_0
BM_IM_17_0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);