package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\A\w+_BM__[0-9]{1,6}_[0-9]{1,6}\z`)
var str = `RP_BM_IM_17_0
BM_IM_17_0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}