const regex = /\A\w+_BM__[0-9]{1,6}_[0-9]{1,6}\z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A\\w+_BM__[0-9]{1,6}_[0-9]{1,6}\\z', 'gm')
const str = `RP_BM_IM_17_0
BM_IM_17_0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}