using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A\w+_BM__[0-9]{1,6}_[0-9]{1,6}\z";
string input = @"RP_BM_IM_17_0
BM_IM_17_0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}