$re = '/^,?|,?$/';
$str = '123123,hehe,123,';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;