use strict;
my $str = '123123,hehe,123,';
my $regex = qr/^,?|,?$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";