using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^,?|,?$";
string substitution = @"";
string input = @"123123,hehe,123,";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}