$re = '/^\p{Zs}*(<(?:/?[xg]\d|[xg]\d/)>\p{Zs}*)+\p{Zs}*$/m';
$str = '<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);