import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\p{Zs}*(<(?:/?[xg]\\d|[xg]\\d/)>\\p{Zs}*)+\\p{Zs}*$";
final String string = "<x1/>\n"
+ "<x1/><x2/>\n"
+ "<g1></g1>\n\n"
+ "<x1/><g1></g1>\n"
+ "<x1/><x1/><x2/>\n\n"
+ " <x1/>\n"
+ " <x1/><x2/>\n"
+ " <g1></g1>\n\n"
+ " <x1/><g1></g1>\n"
+ " <x1/><x1/><x2/>\n\n\n"
+ "<x1/> \n"
+ "<x1/><x2/> \n"
+ " <g1></g1> \n"
+ "<g1> </g1>\n"
+ " <g1> </g1>\n"
+ "<g1> </g1> \n\n"
+ " <x1/><x1/><x2/>\n"
+ " <x1/> <x1/><x2/>\n"
+ " <x1/><x1/> <x2/>\n"
+ " <x1/><x1/> <x2/> \n"
+ " <x1/> <x1/> <x2/>\n"
+ " <x1/> <x1/> <x2/> \n"
+ "<x1/> <x1/> <x2/>\n"
+ "<x1/> <x1/> <x2/> \n"
+ "<x1/><x1/> <x2/>\n"
+ "<x1/><x1/> <x2/> \n\n"
+ " <x1/>\n"
+ " <x1/><x2/>\n"
+ " <g1></g1>\n\n"
+ " <x1/><g1></g1>\n"
+ " <x1/><x1/><x2/>\n\n\n"
+ "<x1/> \n"
+ "<x1/><x2/> \n"
+ " <g1></g1> \n"
+ "<g1> </g1>\n"
+ " <g1> </g1>\n"
+ "<g1> </g1> \n\n"
+ " <x1/><x1/><x2/>\n"
+ " <x1/> <x1/><x2/>\n"
+ " <x1/><x1/> <x2/>\n"
+ " <x1/><x1/> <x2/> \n"
+ " <x1/> <x1/> <x2/>\n"
+ " <x1/> <x1/> <x2/> \n"
+ "<x1/> <x1/> <x2/>\n"
+ "<x1/> <x1/> <x2/> \n"
+ "<x1/><x1/> <x2/>\n"
+ "<x1/><x1/> <x2/> \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}