package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\p{Zs}*(<(?:/?[xg]\d|[xg]\d/)>\p{Zs}*)+\p{Zs}*$`)
var str = `<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}