using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\p{Zs}*(<(?:/?[xg]\d|[xg]\d/)>\p{Zs}*)+\p{Zs}*$";
string input = @"<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<x1/><g1></g1>
<x1/><x1/><x2/>
<x1/>
<x1/><x2/>
<g1></g1>
<g1> </g1>
<g1> </g1>
<g1> </g1>
<x1/><x1/><x2/>
<x1/> <x1/><x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/> <x1/> <x2/>
<x1/><x1/> <x2/>
<x1/><x1/> <x2/>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}