// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mu) ((?:#[\w\d\-\_\ \t]*)+)(@[\w\d\-\_\.\,\!\?\ \t\:\;\%\+\(\)\\\/\'\"\`\%\$]*)?$"#).unwrap();
let string = "ls -la #
ls -la #1
ls -la #2#2
ls -la #1#2#3 @München
ls -la #1# 2#3 @München
ls -la #1# 2 #3 @München
ls -la #1#2 @desc
ls -la #@desc
echo \\#toignore #1
echo \"#toignore\" #1-2
echo \"#toignore\" #@desc
ls -la#toignore
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}