#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu) ((?:#[\w\d\-\_\ \t]*)+)(@[\w\d\-\_\.\,\!\?\ \t\:\;\%\+\(\)\\\/\'\"\`\%\$]*)?$"
Local $sString = "ls -la #" & @CRLF & _
"ls -la #1" & @CRLF & _
"ls -la #2#2" & @CRLF & _
"ls -la #1#2#3 @München" & @CRLF & _
"ls -la #1# 2#3 @München" & @CRLF & _
"ls -la #1# 2 #3 @München" & @CRLF & _
"ls -la #1#2 @desc " & @CRLF & _
"ls -la #@desc " & @CRLF & _
"echo \#toignore #1" & @CRLF & _
"echo "#toignore" #1-2" & @CRLF & _
"echo "#toignore" #@desc" & @CRLF & _
"ls -la#toignore" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")