$re = '/ ((?:#[\w\d\-\_\ \t]*)+)(@[\w\d\-\_\.\,\!\?\ \t\:\;\%\+\(\)\\\\\/\'\"\`\%\$]*)?$/mu';
$str = 'ls -la #
ls -la #1
ls -la #2#2
ls -la #1#2#3 @München
ls -la #1# 2#3 @München
ls -la #1# 2 #3 @München
ls -la #1#2 @desc
ls -la #@desc
echo \\#toignore #1
echo "#toignore" #1-2
echo "#toignore" #@desc
ls -la#toignore
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);