re = / ((?:#[\w\d\-\_\ \t]*)+)(@[\w\d\-\_\.\,\!\?\ \t\:\;\%\+\(\)\\\/\'\"\`\%\$]*)?$/m
str = 'ls -la #
ls -la #1
ls -la #2#2
ls -la #1#2#3 @München
ls -la #1# 2#3 @München
ls -la #1# 2 #3 @München
ls -la #1#2 @desc
ls -la #@desc
echo \\#toignore #1
echo "#toignore" #1-2
echo "#toignore" #@desc
ls -la#toignore
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end