re = /^(?:(http?|s?ftp):\/\/|file:\/\/\/)?(([\P{Cc}]+):([\P{Cc}]+)@)?([a-zA-Z0-9][a-zA-Z0-9.-]*)(:[0-9]{1,5})?($|\/[\w\-\._~:\/?[\]@!\$&'\(\)\*\+,;=.]+(\#[\w]*)?$)/ixm
str = 'sftp://monitoring.fre31/nagios/cgi-bin/status.cgi?hostgroup=fezgz&style=detail
file:///opt/myfile.tar.gz
https://test:ho@mydomain/video.mp4
https://test:ho@mydomain.frho.fr/fhi/subdir/download#jfpze'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end