import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(http?|s?ftp):\\/\\/|file:\\/\\/\\/)?(([\\P{Cc}]+):([\\P{Cc}]+)@)?([a-zA-Z0-9][a-zA-Z0-9.-]*)(:[0-9]{1,5})?($|\\/[\\w\\-\\._~:\\/?[\\]@!\\$&'\\(\\)\\*\\+,;=.]+(\\#[\\w]*)?$)";
final String string = "sftp://monitoring.fre31/nagios/cgi-bin/status.cgi?hostgroup=fezgz&style=detail\n"
+ "file:///opt/myfile.tar.gz\n"
+ "https://test:ho@mydomain/video.mp4\n"
+ "https://test:ho@mydomain.frho.fr/fhi/subdir/download#jfpze";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}