use strict;
my $str = 'sftp://monitoring.fre31/nagios/cgi-bin/status.cgi?hostgroup=fezgz&style=detail
file:///opt/myfile.tar.gz
https://test:ho@mydomain/video.mp4
https://test:ho@mydomain.frho.fr/fhi/subdir/download#jfpze';
my $regex = qr/^(?:(http?|s?ftp):\/\/|file:\/\/\/)?(([\P{Cc}]+):([\P{Cc}]+)@)?([a-zA-Z0-9][a-zA-Z0-9.-]*)(:[0-9]{1,5})?($|\/[\w\-\._~:\/?[\]@!\$&'\(\)\*\+,;=.]+(\#[\w]*)?$)/ixmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}