using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(http?|s?ftp):\/\/|file:\/\/\/)?(([\P{Cc}]+):([\P{Cc}]+)@)?([a-zA-Z0-9][a-zA-Z0-9.-]*)(:[0-9]{1,5})?($|\/[\w\-\._~:\/?[\]@!\$&'\(\)\*\+,;=.]+(\#[\w]*)?$)";
string input = @"sftp://monitoring.fre31/nagios/cgi-bin/status.cgi?hostgroup=fezgz&style=detail
file:///opt/myfile.tar.gz
https://test:ho@mydomain/video.mp4
https://test:ho@mydomain.frho.fr/fhi/subdir/download#jfpze";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}