re = /([A-Z0-9_]+)(\=)(.*\n(?=[A-Z])|.*$)/m
str = '7K_1=one9,o1;;1;8o^&%$#!@#y
K_2=val2
KEY3=val3
KEY4=val4
KEY=valueone
KEY2=value two spaces
KEY3=%specialChars&[*}*&()\';
KEY_4=val4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end