import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z0-9_]+)(\\=)(.*\\n(?=[A-Z])|.*$)";
final String string = "7K_1=one9,o1;;1;8o^&%$#!@#y\n"
+ "K_2=val2\n"
+ "KEY3=val3\n"
+ "KEY4=val4\n"
+ "KEY=valueone\n"
+ "KEY2=value two spaces\n"
+ "KEY3=%specialChars&[*}*&()';\n"
+ "KEY_4=val4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}