$re = '/([A-Z0-9_]+)(\=)(.*\n(?=[A-Z])|.*$)/m';
$str = '7K_1=one9,o1;;1;8o^&%$#!@#y
K_2=val2
KEY3=val3
KEY4=val4
KEY=valueone
KEY2=value two spaces
KEY3=%specialChars&[*}*&()\';
KEY_4=val4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);