#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z0-9_]+)(\=)(.*\n(?=[A-Z])|.*$)"
Local $sString = "7K_1=one9,o1;;1;8o^&%$#!@#y" & @CRLF & _
"K_2=val2" & @CRLF & _
"KEY3=val3" & @CRLF & _
"KEY4=val4" & @CRLF & _
"KEY=valueone" & @CRLF & _
"KEY2=value two spaces" & @CRLF & _
"KEY3=%specialChars&[*}*&()';" & @CRLF & _
"KEY_4=val4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")