re = /[\s-]/m
str = '91-011-23413627
21 011 23412331
91-22-5767801
91-22-5767801
31-424-2339056
91-731-2530659
92-731-2431956
1-731-2530659111
91-731-2431956
111 739 2530659111
091-011-23413627
121 011 23412331
291-322-5767801
491-22-5767801
531-424-2339056123
291-731-2530659123
192-731-2431956
122-731-2530659111
912-731-2431956{-truncated-}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end