import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\s-]";
final String string = "91-011-23413627\n"
+ "21 011 23412331\n"
+ "91-22-5767801\n"
+ "91-22-5767801\n"
+ "31-424-2339056\n"
+ "91-731-2530659\n"
+ "92-731-2431956\n"
+ "1-731-2530659111\n"
+ "91-731-2431956\n"
+ "111 739 2530659111\n"
+ "091-011-23413627\n"
+ "121 011 23412331\n"
+ "291-322-5767801\n"
+ "491-22-5767801\n"
+ "531-424-2339056123\n"
+ "291-731-2530659123\n"
+ "192-731-2431956\n"
+ "122-731-2530659111\n"
+ "912-731-2431956{-truncated-}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}