const regex = /[\s-]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s-]', 'gm')
const str = `91-011-23413627
21 011 23412331
91-22-5767801
91-22-5767801
31-424-2339056
91-731-2530659
92-731-2431956
1-731-2530659111
91-731-2431956
111 739 2530659111
091-011-23413627
121 011 23412331
291-322-5767801
491-22-5767801
531-424-2339056123
291-731-2530659123
192-731-2431956
122-731-2530659111
912-731-2431956{-truncated-}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}