# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\s-]"
test_str = ("91-011-23413627\n"
"21 011 23412331\n"
"91-22-5767801\n"
"91-22-5767801\n"
"31-424-2339056\n"
"91-731-2530659\n"
"92-731-2431956\n"
"1-731-2530659111\n"
"91-731-2431956\n"
"111 739 2530659111\n"
"091-011-23413627\n"
"121 011 23412331\n"
"291-322-5767801\n"
"491-22-5767801\n"
"531-424-2339056123\n"
"291-731-2530659123\n"
"192-731-2431956\n"
"122-731-2530659111\n"
"912-731-2431956{-truncated-}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.