use strict;
my $str = 'CHUOI(<h1>abc)
CHUOI((abc)
CHUOI(abc))
CHUOI((abc)123)
CHUOI(abc)123))
CHUOI(abc))123)
CHUOI((abc)))
CHUOI(abc)123)
CHUOI(abc)ABC(123)
CHUOI(abc(123))
CHUOI(abc)ABC(123))
CHUOI(abc)ABC(132))
CHUOI(abc)))ABC(123(def)))
------------------------------ spec-------------------
CHUOI(<h1>%$#<h1>^@321312*&da<hh131>)anc(abc)
CHUOI(<h1>abc)
CHUOI((<h1<h2>~!@)#$%^&*(*(*)_+**(***$#%$$abc)
CHUOI(abc))
CHUOI((abc)123)
CHUOI(abc)123))
CHUOI(abc))123)
CHUOI((abc)))
CHUOI(abc)123)
CHUOI(abc)ABC(123)
CHUOI(abc(123))
CHUOI(abc)ABC(123))
CHUOI(abc)ABC(132))
CHUOI(abc)))ABC(123(def)))
CHUOI(<h1(abc)ABC(dadahi)';
my $regex = qr/\(\w*\(*[^)]*[^(]*\)*\w*\)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}