const regex = /\(\w*\(*[^)]*[^(]*\)*\w*\)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\w*\\(*[^)]*[^(]*\\)*\\w*\\)+', 'gm')
const str = `CHUOI(<h1>abc)
CHUOI((abc)
CHUOI(abc))
CHUOI((abc)123)
CHUOI(abc)123))
CHUOI(abc))123)
CHUOI((abc)))
CHUOI(abc)123)
CHUOI(abc)ABC(123)
CHUOI(abc(123))
CHUOI(abc)ABC(123))
CHUOI(abc)ABC(132))
CHUOI(abc)))ABC(123(def)))
------------------------------ spec-------------------
CHUOI(<h1>%\$#<h1>^@321312*&da<hh131>)anc(abc)
CHUOI(<h1>abc)
CHUOI((<h1<h2>~!@)#\$%^&*(*(*)_+**(***\$#%\$\$abc)
CHUOI(abc))
CHUOI((abc)123)
CHUOI(abc)123))
CHUOI(abc))123)
CHUOI((abc)))
CHUOI(abc)123)
CHUOI(abc)ABC(123)
CHUOI(abc(123))
CHUOI(abc)ABC(123))
CHUOI(abc)ABC(132))
CHUOI(abc)))ABC(123(def)))
CHUOI(<h1(abc)ABC(dadahi)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}