package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(\w*\(*[^)]*[^(]*\)*\w*\)+`)
var str = `CHUOI(<h1>abc)
CHUOI((abc)
CHUOI(abc))
CHUOI((abc)123)
CHUOI(abc)123))
CHUOI(abc))123)
CHUOI((abc)))
CHUOI(abc)123)
CHUOI(abc)ABC(123)
CHUOI(abc(123))
CHUOI(abc)ABC(123))
CHUOI(abc)ABC(132))
CHUOI(abc)))ABC(123(def)))
------------------------------ spec-------------------
CHUOI(<h1>%$#<h1>^@321312*&da<hh131>)anc(abc)
CHUOI(<h1>abc)
CHUOI((<h1<h2>~!@)#$%^&*(*(*)_+**(***$#%$$abc)
CHUOI(abc))
CHUOI((abc)123)
CHUOI(abc)123))
CHUOI(abc))123)
CHUOI((abc)))
CHUOI(abc)123)
CHUOI(abc)ABC(123)
CHUOI(abc(123))
CHUOI(abc)ABC(123))
CHUOI(abc)ABC(132))
CHUOI(abc)))ABC(123(def)))
CHUOI(<h1(abc)ABC(dadahi)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}