#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(\w*\(*[^)]*[^(]*\)*\w*\)+"
Local $sString = "CHUOI(<h1>abc)" & @CRLF & _
"CHUOI((abc)" & @CRLF & _
"CHUOI(abc))" & @CRLF & _
"CHUOI((abc)123)" & @CRLF & _
"CHUOI(abc)123))" & @CRLF & _
"CHUOI(abc))123)" & @CRLF & _
"CHUOI((abc)))" & @CRLF & _
"CHUOI(abc)123)" & @CRLF & _
"CHUOI(abc)ABC(123)" & @CRLF & _
"CHUOI(abc(123))" & @CRLF & _
"CHUOI(abc)ABC(123))" & @CRLF & _
"CHUOI(abc)ABC(132))" & @CRLF & _
"CHUOI(abc)))ABC(123(def)))" & @CRLF & _
"" & @CRLF & _
"------------------------------ spec-------------------" & @CRLF & _
"CHUOI(<h1>%$#<h1>^@321312*&da<hh131>)anc(abc)" & @CRLF & _
"CHUOI(<h1>abc)" & @CRLF & _
"CHUOI((<h1<h2>~!@)#$%^&*(*(*)_+**(***$#%$$abc)" & @CRLF & _
"CHUOI(abc))" & @CRLF & _
"CHUOI((abc)123)" & @CRLF & _
"CHUOI(abc)123))" & @CRLF & _
"CHUOI(abc))123)" & @CRLF & _
"CHUOI((abc)))" & @CRLF & _
"CHUOI(abc)123)" & @CRLF & _
"CHUOI(abc)ABC(123)" & @CRLF & _
"CHUOI(abc(123))" & @CRLF & _
"CHUOI(abc)ABC(123))" & @CRLF & _
"CHUOI(abc)ABC(132))" & @CRLF & _
"CHUOI(abc)))ABC(123(def)))" & @CRLF & _
"" & @CRLF & _
"CHUOI(<h1(abc)ABC(dadahi)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")