import Foundation
let pattern = #"((http(s)?:\/\/)?(www\.)?youtube\.com\/@.*)|((http(s)?:\/\/)?(www\.)?twitch\.tv\/.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.youtube.com/@mallusrgreat
http://www.youtube.com/@mallusrgreat
http://youtube.com/@mallusrgreat
https://youtube.com/@mallusrgreat
https://www.youtube.com/@mallusrgreat/
http://www.youtube.com/@mallusrgreat/
http://youtube.com/@mallusrgreat/
https://youtube.com/@mallusrgreat/
asdsadhttp://youtube.com/@mall
https://www.twitch.tv/aus24
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)