const regex = /((http(s)?:\/\/)?(www\.)?youtube\.com\/@.*)|((http(s)?:\/\/)?(www\.)?twitch\.tv\/.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http(s)?:\\\/\\\/)?(www\\.)?youtube\\.com\\\/@.*)|((http(s)?:\\\/\\\/)?(www\\.)?twitch\\.tv\\\/.*)', 'g')
const str = `https://www.youtube.com/@mallusrgreat
http://www.youtube.com/@mallusrgreat
http://youtube.com/@mallusrgreat
https://youtube.com/@mallusrgreat
https://www.youtube.com/@mallusrgreat/
http://www.youtube.com/@mallusrgreat/
http://youtube.com/@mallusrgreat/
https://youtube.com/@mallusrgreat/
asdsadhttp://youtube.com/@mall
https://www.twitch.tv/aus24
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}