#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((http(s)?:\/\/)?(www\.)?youtube\.com\/@.*)|((http(s)?:\/\/)?(www\.)?twitch\.tv\/.*)"
Local $sString = "https://www.youtube.com/@mallusrgreat" & @CRLF & _
"http://www.youtube.com/@mallusrgreat" & @CRLF & _
"http://youtube.com/@mallusrgreat" & @CRLF & _
"https://youtube.com/@mallusrgreat" & @CRLF & _
"https://www.youtube.com/@mallusrgreat/" & @CRLF & _
"http://www.youtube.com/@mallusrgreat/" & @CRLF & _
"http://youtube.com/@mallusrgreat/" & @CRLF & _
"https://youtube.com/@mallusrgreat/" & @CRLF & _
"asdsadhttp://youtube.com/@mall" & @CRLF & _
"https://www.twitch.tv/aus24" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")