$re = '/((http(s)?:\/\/)?(www\.)?youtube\.com\/@.*)|((http(s)?:\/\/)?(www\.)?twitch\.tv\/.*)/';
$str = 'https://www.youtube.com/@mallusrgreat
http://www.youtube.com/@mallusrgreat
http://youtube.com/@mallusrgreat
https://youtube.com/@mallusrgreat
https://www.youtube.com/@mallusrgreat/
http://www.youtube.com/@mallusrgreat/
http://youtube.com/@mallusrgreat/
https://youtube.com/@mallusrgreat/
asdsadhttp://youtube.com/@mall
https://www.twitch.tv/aus24
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);