// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{2}\.([0-9]{1,2})\.([0-9]{1,2})\.(\d)$").unwrap();
let string = "21.02.28.1
21.02.28.1
patate";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}