$re = '/^[0-9]{2}\.([0-9]{1,2})\.([0-9]{1,2})\.(\d)$/m';
$str = '21.02.28.1
21.02.28.1
patate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);