package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{2}\.([0-9]{1,2})\.([0-9]{1,2})\.(\d)$`)
var str = `21.02.28.1
21.02.28.1
patate`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}