const regex = /^[0-9]{2}\.([0-9]{1,2})\.([0-9]{1,2})\.(\d)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{2}\\.([0-9]{1,2})\\.([0-9]{1,2})\\.(\\d)$', 'mg')
const str = `21.02.28.1
21.02.28.1
patate`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}